Your Name 2 years ago
parent
commit
bde5aa31cd
3 changed files with 4 additions and 198 deletions
  1. 0 196
      001.openwrt_cgminer_patch
  2. 2 0
      build-ants3.sh
  3. 2 2
      build-gekko_new.sh

+ 0 - 196
001.openwrt_cgminer_patch

@@ -1,196 +0,0 @@
-diff --git a/dragonmint_t1.c "b/dragonmint_t1.c"
-index 9241073..44cd096 100644
---- a/dragonmint_t1.c
-+++ "b/dragonmint_t1.c"
-@@ -11,7 +11,7 @@
- #include <assert.h>
- #include <fcntl.h>
- #include <limits.h>
--#include <unistd.h>
-+//#include <unistd.h> //openwrt mod//
- #include <stdbool.h>
- 
- #include "logging.h"
-diff --git a/driver-avalon.c "b/driver-avalon.c"
-index 2210130..4ed159b 100644
---- a/driver-avalon.c
-+++ "b/driver-avalon.c"
-@@ -19,7 +19,7 @@
- #include <sys/types.h>
- #include <ctype.h>
- #include <dirent.h>
--#include <unistd.h>
-+//#include <unistd.h> //mod openwrt//
- #include <time.h>
- #ifndef WIN32
-   #include <sys/select.h>
-diff --git a/diver-avalon2.c "b/driver-avalon2.c"
-index c3fa18a..738a775 100644
---- a/driver-avalon2.c
-+++ "b/driver-avalon2.c"
-@@ -18,7 +18,7 @@
- #include <sys/time.h>
- #include <sys/types.h>
- #include <dirent.h>
--#include <unistd.h>
-+//#include <unistd.h> //openwrt/mod
- #ifndef WIN32
-   #include <termios.h>
-   #include <sys/stat.h>
-diff --git a/driver-bflsc.c "b/driver-bflsc.c"
-index ce17555..50be2f5 100644
---- a/driver-bflsc.c
-+++ "b/driver-bflsc.c"
-@@ -18,7 +18,7 @@
- #include <string.h>
- #include <strings.h>
- #include <sys/time.h>
--#include <unistd.h>
-+//#include <unistd.h> //openwrt mod//
- 
- #include "compat.h"
- #include "miner.h"
-diff --git a/driver-bitforce.c "b/driver-bitforce.c"
-index e8a912b..cb91173 100644
---- a/driver-bitforce.c
-+++ "b/driver-bitforce.c"
-@@ -17,7 +17,7 @@
- #include <stdio.h>
- #include <strings.h>
- #include <sys/time.h>
--#include <unistd.h>
-+//#include <unistd.h> // openwrt mod//
- 
- #include "compat.h"
- #include "miner.h"
-diff --git a/driver-blockerupter.c "b/driver-blockerupter.c"
-index 734dd14..c3c2a27 100644
---- a/driver-blockerupter.c
-+++ "b/driver-blockerupter.c"
-@@ -5,7 +5,7 @@
- #include <sys/time.h>
- #include <sys/types.h>
- #include <dirent.h>
--#include <unistd.h>
-+//#include <unistd.h> //openwrt mod//
- #include <math.h>
- #ifndef WIN32
- #include <termios.h>
-diff --git a/driver-btm-soc.c "b/driver-btm-soc.c"
-index 3d439b4..7c22ddc 100644
---- a/driver-btm-soc.c
-+++ "b/driver-btm-soc.c"
-@@ -16,7 +16,8 @@
- #include <sys/time.h>
- #include <sys/types.h>
- #include <dirent.h>
--#include <unistd.h>
-+//#include <unistd.h> //openwrt mod//
-+
- #include <sys/mman.h>
- #include <math.h>
- 
-diff --git a/driver-gekko.c "b/driver-gekko.c"
-index c41a081..478284f 100644
---- a/driver-gekko.c
-+++ "b/driver-gekko.c"
-@@ -12,7 +12,7 @@
- #include "driver-gekko.h"
- #include "crc.h"
- #include "compat.h"
--#include <unistd.h>
-+//#include <unistd.h> //openwrt mod//
- 
- #ifdef __GNUC__
- #if __GNUC__ >= 7
-diff --git a/driver-icarus.c "b/driver-icarus.c"
-index 0a20c63..d295239 100644
---- a/driver-icarus.c
-+++ "b/driver-icarus.c"
-@@ -37,7 +37,7 @@
- #include <stdio.h>
- #include <strings.h>
- #include <sys/time.h>
--#include <unistd.h>
-+//#include <unistd.h> // openwrt mod //
- #include <math.h>
- 
- #include "config.h"
-diff --git a/driver-klondike.c "b/driver-klondike.c"
-index 61981d8..648e1e6 100644
---- a/driver-klondike.c
-+++ "b/driver-klondike.c"
-@@ -16,7 +16,7 @@
- #include <stdio.h>
- #include <strings.h>
- #include <sys/time.h>
--#include <unistd.h>
-+//#include <unistd.h> //openwrt mod//
- #include <math.h>
- 
- #include "config.h"
-diff --git a/driver-knc.c "b/driver-knc.c"
-index 564d27d..34d1989 100644
---- a/driver-knc.c
-+++ "b/driver-knc.c"
-@@ -13,7 +13,7 @@
- #include <assert.h>
- #include <fcntl.h>
- #include <limits.h>
--#include <unistd.h>
-+//#include <unistd.h> //openwrt mod//
- #include <sys/ioctl.h>
- #include <sys/time.h>
- #include <linux/types.h>
-diff --git a/driver-modminer.c "b/driver-modminer.c"
-index d3dd946..8094246 100644
---- a/driver-modminer.c
-+++ "b/driver-modminer.c"
-@@ -12,7 +12,7 @@
- 
- #include <stdarg.h>
- #include <stdio.h>
--#include <unistd.h>
-+//#include <unistd.h> //openwrt mod//
- #include <math.h>
- 
- #include "logging.h"
-diff --git a/driver-spondoolies-sp10.c "b/driver-spondoolies-sp10.c"
-index c2a983a..9a0f115 100644
---- a/driver-spondoolies-sp10.c
-+++ "b/driver-spondoolies-sp10.c"
-@@ -23,7 +23,7 @@
- #include <stdio.h>
- #include <strings.h>
- #include <sys/time.h>
--#include <unistd.h>
-+//#include <unistd.h> //openwrt mod//
- #include <assert.h>
- #include <time.h>
- #include <sys/socket.h>
-diff --git a/driver-spondoolies-sp30.c "b/driver-spondoolies-sp30.c"
-index 1a71d12..b0bdb25 100644
---- a/driver-spondoolies-sp30.c
-+++ "b/driver-spondoolies-sp30.c"
-@@ -23,7 +23,7 @@
- #include <stdio.h>
- #include <strings.h>
- #include <sys/time.h>
--#include <unistd.h>
-+//#include <unistd.h> //openwrt mod//
- #include <assert.h>
- #include <time.h>
- #include <sys/socket.h>
-diff --git a/usbutils.c "b/usbutils.c"
-index d6c9ad6..ff3ad1e 100644
---- a/usbutils.c
-+++ "b/usbutils.c"
-@@ -4112,7 +4112,7 @@ void usb_initialise(void)
- 
- #ifndef WIN32
- #include <errno.h>
--#include <unistd.h>
-+//#include <unistd.h> //openwrt mod//
- #include <sys/stat.h>
- #include <sys/file.h>
- #include <fcntl.h>

+ 2 - 0
build-ants3.sh

@@ -108,7 +108,9 @@ prepare_source() {
                 ;;
                 ;;
         esac
         esac
     fi
     fi
+
 sed -i -e "s/git:\/\/github.com/http:\/\/github.com/g" openwrt/package/network/services/odhcpd/Makefile
 sed -i -e "s/git:\/\/github.com/http:\/\/github.com/g" openwrt/package/network/services/odhcpd/Makefile
+
     [ ! -e dl ] && mkdir dl
     [ ! -e dl ] && mkdir dl
     cd ${OPENWRT_DIR}
     cd ${OPENWRT_DIR}
     ln -sf ../dl
     ln -sf ../dl

+ 2 - 2
build-gekko_new.sh

@@ -19,11 +19,11 @@ SCRIPT_VERSION=30092017
 [ -z "${AVA_MACHINE}" ] && AVA_MACHINE=gekko
 [ -z "${AVA_MACHINE}" ] && AVA_MACHINE=gekko
 
 
 # Support target board: rpi2-modelb, rpi1-modelb, tl-wr703n-v1, tl-mr3020-v1
 # Support target board: rpi2-modelb, rpi1-modelb, tl-wr703n-v1, tl-mr3020-v1
-[ -z "${AVA_TARGET_BOARD}" ] && AVA_TARGET_BOARD=rpi3-modelb
+[ -z "${AVA_TARGET_BOARD}" ] && AVA_TARGET_BOARD=tl-mr3020-v1
 
 
 # OpenWrt repo
 # OpenWrt repo
 gekko_owrepo="http://gogserver.dnsalias.com:3000/wareck/openwrt_chaos_calmer.git@master"
 gekko_owrepo="http://gogserver.dnsalias.com:3000/wareck/openwrt_chaos_calmer.git@master"
-if [ "${AVA_TARGET_BOARD}" == "rpî3" ]; then
+if [ "${AVA_TARGET_BOARD}" == "rpi3" ]; then
 gekko_owrepo="https://github.com/openwrt/openwrt.git@e046500"
 gekko_owrepo="https://github.com/openwrt/openwrt.git@e046500"
 fi
 fi