|
@@ -10,26 +10,8 @@ include $(TOPDIR)/rules.mk
|
|
|
|
|
|
PKG_NAME:=cgminer
|
|
|
|
|
|
-ifeq ($(CONFIG_CGMINER_AVALON4),y)
|
|
|
- PKG_VERSION:=git-$(shell git ls-remote https://github.com/csa402/cgminer-gekko avalon4 | cut -f1 | cut -c1-7)
|
|
|
- PKG_REV:=avalon4
|
|
|
-endif
|
|
|
-ifeq ($(CONFIG_CGMINER_GEKKO),y)
|
|
|
- PKG_VERSION:=git-$(shell git ls-remote https://github.com/csa402/cgminer-gekko.git master | cut -f1 | cut -c1-7)
|
|
|
- PKG_REV:=master
|
|
|
-endif
|
|
|
-ifeq ($(CONFIG_CGMINER_ROCKMINER),y)
|
|
|
- PKG_VERSION:=git-$(shell git ls-remote https://github.com/wareck/cgminer-gekko.git master | cut -f1 | cut -c1-7)
|
|
|
- PKG_REV:=f8b12c8f424ef11d65be425db243416e9d0ef1d3
|
|
|
-endif
|
|
|
-
|
|
|
-#ifeq ($(CONFIG_CGMINER_BITMAIN),y)
|
|
|
-# PKG_VERSION:=git-$(shell git ls-remote https://github.com/csa402/cgminer-ants3.git master | cut -f1 | cut -c1-7)
|
|
|
-# PKG_REV:=master
|
|
|
-#endif
|
|
|
-
|
|
|
ifeq ($(CONFIG_CGMINER_BITMAIN),y)
|
|
|
- PKG_VERSION:=git-$(shell git ls-remote https://github.com/csa402/cgminer-ants3.git master | cut -f1 | cut -c1-7)
|
|
|
+ PKG_VERSION:=git-$(shell git ls-remote http://gogserver.dnsalias.com:3000/wareck/cgminer-ants3.git master | cut -f1 | cut -c1-7)
|
|
|
PKG_REV:=master
|
|
|
endif
|
|
|
|
|
@@ -40,14 +22,8 @@ PKG_RELEASE:=1
|
|
|
PKG_INSTALL:=1
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_REV).tar.bz2
|
|
|
-ifeq ($(CONFIG_CGMINER_AVALON4),y)
|
|
|
- PKG_SOURCE_URL:=git://github.com/wareck/cgminer-gekko.git
|
|
|
-endif
|
|
|
-ifeq ($(CONFIG_CGMINER_GEKKO),y)
|
|
|
- PKG_SOURCE_URL:=git://github.com/csa402/cgminer-gekko.git
|
|
|
-endif
|
|
|
ifeq ($(CONFIG_CGMINER_BITMAIN),y)
|
|
|
- PKG_SOURCE_URL:=git://github.com/csa402/cgminer-ants3.git
|
|
|
+ PKG_SOURCE_URL:=http://gogserver.dnsalias.com:3000/wareck/cgminer-ants3.git
|
|
|
endif
|
|
|
|
|
|
PKG_SOURCE_PROTO:=git
|
|
@@ -85,18 +61,6 @@ endef
|
|
|
|
|
|
TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
|
|
|
|
|
|
-ifeq ($(CONFIG_CGMINER_AVALON1),y)
|
|
|
- CONFIGURE_ARGS += --enable-avalon
|
|
|
-endif
|
|
|
-ifeq ($(CONFIG_CGMINER_AVALON2),y)
|
|
|
- CONFIGURE_ARGS += --enable-avalon2
|
|
|
-endif
|
|
|
-ifeq ($(CONFIG_CGMINER_AVALON4),y)
|
|
|
- CONFIGURE_ARGS += --enable-avalon4
|
|
|
-endif
|
|
|
-ifeq ($(CONFIG_CGMINER_GEKKO),y)
|
|
|
- CONFIGURE_ARGS += --enable-gekko
|
|
|
-endif
|
|
|
ifeq ($(CONFIG_CGMINER_BITMAIN),y)
|
|
|
CONFIGURE_ARGS += --without-curses --enable-ants3
|
|
|
endif
|
|
@@ -120,28 +84,6 @@ define Package/cgminer/install
|
|
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/cgminer-api $(1)/usr/bin
|
|
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/cgminer $(1)/usr/bin
|
|
|
|
|
|
-ifeq ($(CONFIG_CGMINER_AVALON1),y)
|
|
|
- $(INSTALL_BIN) $(FILES_DIR)/cgminer-avalon1-monitor $(1)/usr/bin/cgminer-monitor
|
|
|
- $(INSTALL_BIN) $(FILES_DIR)/cgminer.avalon1.init $(1)/etc/init.d/cgminer
|
|
|
- $(CP) $(FILES_DIR)/cgminer.avalon1.config $(1)/etc/config/cgminer
|
|
|
-endif
|
|
|
-ifeq ($(CONFIG_CGMINER_AVALON2),y)
|
|
|
- $(INSTALL_BIN) $(FILES_DIR)/cgminer-avalon2-monitor $(1)/usr/bin/cgminer-monitor
|
|
|
- $(INSTALL_BIN) $(FILES_DIR)/cgminer.avalon2.init $(1)/etc/init.d/cgminer
|
|
|
- $(CP) $(FILES_DIR)/cgminer.avalon2.config $(1)/etc/config/cgminer
|
|
|
-endif
|
|
|
-ifeq ($(CONFIG_CGMINER_AVALON4),y)
|
|
|
- $(INSTALL_BIN) $(FILES_DIR)/cgminer-avalon4-monitor $(1)/usr/bin/cgminer-monitor
|
|
|
- $(INSTALL_BIN) $(FILES_DIR)/cgminer.avalon4.init $(1)/etc/init.d/cgminer
|
|
|
- $(CP) $(FILES_DIR)/cgminer.avalon4.config $(1)/etc/config/cgminer
|
|
|
- $(INSTALL_BIN) $(FILES_DIR)/mm-avalon4-upgrade $(1)/usr/bin/mmupgrade
|
|
|
-endif
|
|
|
-ifeq ($(CONFIG_CGMINER_GEKKO),y)
|
|
|
- $(INSTALL_BIN) $(FILES_DIR)/cgminer-gekko-monitor $(1)/usr/bin/cgminer-monitor
|
|
|
- $(INSTALL_BIN) $(FILES_DIR)/cgminer.gekko.init $(1)/etc/init.d/cgminer
|
|
|
- $(CP) $(FILES_DIR)/cgminer.gekko.config $(1)/etc/config/cgminer
|
|
|
- $(INSTALL_BIN) $(FILES_DIR)/mm-gekko-upgrade $(1)/usr/bin/mmupgrade
|
|
|
-endif
|
|
|
ifeq ($(CONFIG_CGMINER_BITMAIN),y)
|
|
|
$(INSTALL_BIN) $(FILES_DIR)/cgminer-bitmain-monitor $(1)/usr/bin/cgminer-monitor
|
|
|
$(INSTALL_BIN) $(FILES_DIR)/cgminer.bitmain.init $(1)/etc/init.d/cgminer
|